import Foundation
let pattern = #"translate\((\-?\d+\.?\d*)\,\s?(\-?\d+\.?\d*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
translate(-140.897155855, 10.897155855) scale(2.1885874025214793)
translate(-140.897155855, -123.897155855) scale(2.1885874025214793)
scale(2.1885874025214793) translate(-140.897155855, -123.897155855)
scale(2.1885874025214793) translate(1, 0)
scale(2.1885874025214793) translate(0,0)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)