using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"translate\((\-?\d+\.?\d*)\,\s?(\-?\d+\.?\d*)";
string input = @"translate(-140.897155855, 10.897155855) scale(2.1885874025214793)
translate(-140.897155855, -123.897155855) scale(2.1885874025214793)
scale(2.1885874025214793) translate(-140.897155855, -123.897155855)
scale(2.1885874025214793) translate(1, 0)
scale(2.1885874025214793) translate(0,0)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}