re = /translate\((\-?\d+\.?\d*)\,\s?(\-?\d+\.?\d*)/m
str = 'translate(-140.897155855, 10.897155855) scale(2.1885874025214793)
translate(-140.897155855, -123.897155855) scale(2.1885874025214793)
scale(2.1885874025214793) translate(-140.897155855, -123.897155855)
scale(2.1885874025214793) translate(1, 0)
scale(2.1885874025214793) translate(0,0)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end