const regex = /translate\((\-?\d+\.?\d*)\,\s?(\-?\d+\.?\d*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('translate\\((\\-?\\d+\\.?\\d*)\\,\\s?(\\-?\\d+\\.?\\d*)', 'gm')
const str = `translate(-140.897155855, 10.897155855) scale(2.1885874025214793)
translate(-140.897155855, -123.897155855) scale(2.1885874025214793)
scale(2.1885874025214793) translate(-140.897155855, -123.897155855)
scale(2.1885874025214793) translate(1, 0)
scale(2.1885874025214793) translate(0,0)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}