$re = '/translate\((\-?\d+\.?\d*)\,\s?(\-?\d+\.?\d*)/m';
$str = 'translate(-140.897155855, 10.897155855) scale(2.1885874025214793)
translate(-140.897155855, -123.897155855) scale(2.1885874025214793)
scale(2.1885874025214793) translate(-140.897155855, -123.897155855)
scale(2.1885874025214793) translate(1, 0)
scale(2.1885874025214793) translate(0,0)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);