// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(<a\s+[^>]+>)").unwrap();
let string = "<a href=\"http://www.tmprod.com/wp-content/uploads/2015/08/wfesix1zoom.png\"><img class=\"alignnone size-full wp-image-11943\" src=\"http://www.tmprod.com/wp-content/uploads/2015/03/work-essentials-1.jpg\" alt=\"work-essentials-1\" width=\"440\" height=\"150\" /></a><a href=\"http://www.tmprod.com/wp-content/uploads/2015/08/wfesix2zoom.png\"><img class=\"alignnone size-full wp-image-11944\" src=\"http://www.tmprod.com/wp-content/uploads/2015/03/work-essentials-2.jpg\" alt=\"work-essentials-2\" width=\"440\" height=\"150\" /></a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}