use strict;
my $str = '<a href="http://www.tmprod.com/wp-content/uploads/2015/08/wfesix1zoom.png"><img class="alignnone size-full wp-image-11943" src="http://www.tmprod.com/wp-content/uploads/2015/03/work-essentials-1.jpg" alt="work-essentials-1" width="440" height="150" /></a><a href="http://www.tmprod.com/wp-content/uploads/2015/08/wfesix2zoom.png"><img class="alignnone size-full wp-image-11944" src="http://www.tmprod.com/wp-content/uploads/2015/03/work-essentials-2.jpg" alt="work-essentials-2" width="440" height="150" /></a>';
my $regex = qr~(<a\s+[^>]+>)~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}