using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a\s+[^>]+>)";
string input = @"<a href=""http://www.tmprod.com/wp-content/uploads/2015/08/wfesix1zoom.png""><img class=""alignnone size-full wp-image-11943"" src=""http://www.tmprod.com/wp-content/uploads/2015/03/work-essentials-1.jpg"" alt=""work-essentials-1"" width=""440"" height=""150"" /></a><a href=""http://www.tmprod.com/wp-content/uploads/2015/08/wfesix2zoom.png""><img class=""alignnone size-full wp-image-11944"" src=""http://www.tmprod.com/wp-content/uploads/2015/03/work-essentials-2.jpg"" alt=""work-essentials-2"" width=""440"" height=""150"" /></a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}