import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<a\\s+[^>]+>)";
final String string = "<a href=\"http://www.tmprod.com/wp-content/uploads/2015/08/wfesix1zoom.png\"><img class=\"alignnone size-full wp-image-11943\" src=\"http://www.tmprod.com/wp-content/uploads/2015/03/work-essentials-1.jpg\" alt=\"work-essentials-1\" width=\"440\" height=\"150\" /></a><a href=\"http://www.tmprod.com/wp-content/uploads/2015/08/wfesix2zoom.png\"><img class=\"alignnone size-full wp-image-11944\" src=\"http://www.tmprod.com/wp-content/uploads/2015/03/work-essentials-2.jpg\" alt=\"work-essentials-2\" width=\"440\" height=\"150\" /></a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}