$re = '~(<a\s+[^>]+>)~m';
$str = '<a href="http://www.tmprod.com/wp-content/uploads/2015/08/wfesix1zoom.png"><img class="alignnone size-full wp-image-11943" src="http://www.tmprod.com/wp-content/uploads/2015/03/work-essentials-1.jpg" alt="work-essentials-1" width="440" height="150" /></a><a href="http://www.tmprod.com/wp-content/uploads/2015/08/wfesix2zoom.png"><img class="alignnone size-full wp-image-11944" src="http://www.tmprod.com/wp-content/uploads/2015/03/work-essentials-2.jpg" alt="work-essentials-2" width="440" height="150" /></a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);