import Foundation
let pattern = #"http://(.*)\.eleveo.com/auth(/)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"http://jahody.eleveo.com/auth"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"http://${1}.eleveo.com/auth/${1}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)