use strict;
my $str = 'http://jahody.eleveo.com/auth';
my $regex = qr`http://(.*)\.eleveo.com/auth(/)?`mp;
my $subst = 'http://${1}.eleveo.com/auth/${1}';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";