package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)http://(.*)\.eleveo.com/auth(/)?`)
var str = `http://jahody.eleveo.com/auth`
var substitution = "http://${1}.eleveo.com/auth/${1}"
fmt.Println(re.ReplaceAllString(str, substitution))
}