$re = '`http://(.*)\.eleveo.com/auth(/)?`m';
$str = 'http://jahody.eleveo.com/auth';
$subst = "http://${1}.eleveo.com/auth/${1}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;