#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)http://(.*)\.eleveo.com/auth(/)?"
Local $sString = "http://jahody.eleveo.com/auth"
Local $sSubst = "http://${1}.eleveo.com/auth/${1}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)