// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([(\s0-9]+)([lL]\.?)([)\s]+)").unwrap();
let string = "2 l.
2l.
2l
cuatro l
lateral
1l.
l.
L.
ls.
Ls.
L
l
(l)
(L)
(ls.)
(Ls.)
(ls)
(Ls)
l.
l.
L
l
3l.
2l.
2l.
4 l.
4l
5L.
lateral
literal
1 litro
1l.
1 l. de agua
1/2 L. de zumo
(l)
1l
l.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}