use strict;
my $str = '2 l.
2l.
2l
cuatro l
lateral
1l.
l.
L.
ls.
Ls.
L
l
(l)
(L)
(ls.)
(Ls.)
(ls)
(Ls)
l.
l.
L
l
3l.
2l.
2l.
4 l.
4l
5L.
lateral
literal
1 litro
1l.
1 l. de agua
1/2 L. de zumo
(l)
1l
l.
';
my $regex = qr/([(\s0-9]+)([lL]\.?)([)\s]+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}