import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([(\\s0-9]+)([lL]\\.?)([)\\s]+)";
final String string = "2 l. \n"
+ "2l. \n"
+ "2l \n"
+ "cuatro l \n"
+ "lateral \n"
+ "1l.\n"
+ "l.\n"
+ "L.\n"
+ "ls.\n"
+ "Ls.\n"
+ "L \n"
+ "l \n"
+ "(l)\n"
+ "(L)\n"
+ "(ls.)\n"
+ "(Ls.)\n"
+ "(ls)\n"
+ "(Ls)\n"
+ "l.\n"
+ " l.\n"
+ " L \n"
+ " l \n"
+ "3l.\n"
+ "2l.\n"
+ " 2l.\n"
+ "4 l.\n"
+ "4l\n"
+ "5L.\n"
+ "lateral\n"
+ "literal\n"
+ "1 litro\n"
+ "1l.\n"
+ "1 l. de agua\n"
+ "1/2 L. de zumo\n"
+ "(l)\n"
+ "1l \n"
+ " l. \n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}