re = /([(\s0-9]+)([lL]\.?)([)\s]+)/
str = '2 l.
2l.
2l
cuatro l
lateral
1l.
l.
L.
ls.
Ls.
L
l
(l)
(L)
(ls.)
(Ls.)
(ls)
(Ls)
l.
l.
L
l
3l.
2l.
2l.
4 l.
4l
5L.
lateral
literal
1 litro
1l.
1 l. de agua
1/2 L. de zumo
(l)
1l
l.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end