const regex = /^0[.\(\/]5[0-9][0-9][.\)\/][.\ \/][1-9]([0-9]){2}[.\-\/]([0-9]){4}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^0[.\\(\\\/]5[0-9][0-9][.\\)\\\/][.\\ \\\/][1-9]([0-9]){2}[.\\-\\\/]([0-9]){4}$', '')
const str = `0(545) 355-1531`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);