# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^0[.\(\\/]5[0-9][0-9][.\)\\/][.\ \\/][1-9]([0-9]){2}[.\-\\/]([0-9]){4}$//;t' <<< "0(545) 355-1531"