import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^0[.\\(\\/]5[0-9][0-9][.\\)\\/][.\\ \\/][1-9]([0-9]){2}[.\\-\\/]([0-9]){4}$";
final String string = "0(545) 355-1531";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}