re = /(?!.?@.+)\s[\w\,\.\!\'\(\)\#]+/m
str = '“@united: @Addair We hope you don\'t miss your connection. For help with re-Flight Booking Problems please Follow us & DM your confirmation. ^CPâ€done thx
=@united never fails to have delayed flights 😡
=@united I sent my details to the customer care link you sent me Almost a month ago and no response.
@united Hate when I get bumped out of the seat I\'ve selected (& empty row) and moved to another seat (non-empty). #1K #flt803 #nonupgrade!
Meanwhile, they fucked my flight. @united: The festivities are already in full swing at the United Fairway Club, overlooking the 17th hole..'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end