# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?!.?@.+)\s[\w\,\.\!\'\(\)\#]+"
test_str = ("“@united: @Addair We hope you don't miss your connection. For help with re-Flight Booking Problems please Follow us & DM your confirmation. ^CPâ€done thx\n"
"=@united never fails to have delayed flights 😡\n"
"=@united I sent my details to the customer care link you sent me Almost a month ago and no response.\n"
"@united Hate when I get bumped out of the seat I've selected (& empty row) and moved to another seat (non-empty). #1K #flt803 #nonupgrade!\n"
"Meanwhile, they fucked my flight. @united: The festivities are already in full swing at the United Fairway Club, overlooking the 17th hole..")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.