use strict;
my $str = '“@united: @Addair We hope you don\'t miss your connection. For help with re-Flight Booking Problems please Follow us & DM your confirmation. ^CPâ€done thx
=@united never fails to have delayed flights 😡
=@united I sent my details to the customer care link you sent me Almost a month ago and no response.
@united Hate when I get bumped out of the seat I\'ve selected (& empty row) and moved to another seat (non-empty). #1K #flt803 #nonupgrade!
Meanwhile, they fucked my flight. @united: The festivities are already in full swing at the United Fairway Club, overlooking the 17th hole..';
my $regex = qr/(?!.?@.+)\s[\w\,\.\!\'\(\)\#]+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}