import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!.?@.+)\\s[\\w\\,\\.\\!\\'\\(\\)\\#]+";
final String string = "“@united: @Addair We hope you don't miss your connection. For help with re-Flight Booking Problems please Follow us & DM your confirmation. ^CPâ€done thx\n"
+ "=@united never fails to have delayed flights 😡\n"
+ "=@united I sent my details to the customer care link you sent me Almost a month ago and no response.\n"
+ "@united Hate when I get bumped out of the seat I've selected (& empty row) and moved to another seat (non-empty). #1K #flt803 #nonupgrade!\n"
+ "Meanwhile, they fucked my flight. @united: The festivities are already in full swing at the United Fairway Club, overlooking the 17th hole..";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}