import Foundation
let pattern = #"Your BANK a\/c xxxx (\d{4}) will be debited for Rs ([\d|,]+\.*\d+) towards HDFCBank CreditCard payment on (\d{2}\/\w{3}\/\d{4}) ."#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Your BANK a/c xxxx 4114 will be debited for Rs 97856.5 towards HDFCBank CreditCard payment on 22/FEB/2016 ."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}