# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Your BANK a\/c xxxx (\d{4}) will be debited for Rs ([\d|,]+\.*\d+) towards HDFCBank CreditCard payment on (\d{2}\/\w{3}\/\d{4}) ."
test_str = "Your BANK a/c xxxx 4114 will be debited for Rs 97856.5 towards HDFCBank CreditCard payment on 22/FEB/2016 ."
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.