const regex = /Your BANK a\/c xxxx (\d{4}) will be debited for Rs ([\d|,]+\.*\d+) towards HDFCBank CreditCard payment on (\d{2}\/\w{3}\/\d{4}) ./;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Your BANK a\\\/c xxxx (\\d{4}) will be debited for Rs ([\\d|,]+\\.*\\d+) towards HDFCBank CreditCard payment on (\\d{2}\\\/\\w{3}\\\/\\d{4}) .', '')
const str = `Your BANK a/c xxxx 4114 will be debited for Rs 97856.5 towards HDFCBank CreditCard payment on 22/FEB/2016 .`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}