#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Your BANK a\/c xxxx (\d{4}) will be debited for Rs ([\d|,]+\.*\d+) towards HDFCBank CreditCard payment on (\d{2}\/\w{3}\/\d{4}) ."
Local $sString = "Your BANK a/c xxxx 4114 will be debited for Rs 97856.5 towards HDFCBank CreditCard payment on 22/FEB/2016 ."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")