re = /Your BANK a\/c xxxx (\d{4}) will be debited for Rs ([\d|,]+\.*\d+) towards HDFCBank CreditCard payment on (\d{2}\/\w{3}\/\d{4}) ./
str = 'Your BANK a/c xxxx 4114 will be debited for Rs 97856.5 towards HDFCBank CreditCard payment on 22/FEB/2016 .'
# Print the match result
str.match(re) do |match|
puts match.to_s
end