import Foundation
// WARNING: You included a flag that Swift doesn't support: U
// When this flag is set, it inverts the "greediness" of the quantifiers so that they are not greedy by default, but become greedy if followed by '?'.
// As an alternative, this effect can also be achieved by setting a (?U) modifier setting within the pattern or by a question mark behind a quantifier (e.g. .*?).
let pattern = #"(?<=\d{6})(\d+)(?=\d{4})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
4548812049400004
5229782641993099
345678000000007
6362970000457013
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"X"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)