# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\d{6})(\d+)(?=\d{4})/X/Ug;t' <<< "4548812049400004
5229782641993099
345678000000007
6362970000457013"