const regex = /(?<=\d{6})(\d+)(?=\d{4})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\d{6})(\\d+)(?=\\d{4})', 'g')
const str = `4548812049400004
5229782641993099
345678000000007
6362970000457013`;
const subst = `X`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);