$re = '/(?<=\d{6})(\d+)(?=\d{4})/U';
$str = '4548812049400004
5229782641993099
345678000000007
6362970000457013';
$subst = "X";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;