using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\d{6})(\d+)(?=\d{4})";
string substitution = @"X";
string input = @"4548812049400004
5229782641993099
345678000000007
6362970000457013";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}