import Foundation
let pattern = #"<(wp:postmeta)>\s*<(wp:meta_key)>\s*wpcf-lookbook-front-image\s*<\/\2>\s*<(wp:meta_value)>[\s\S]*?<\/\3>\s*<\/\1>\s*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<wp:postmeta>
<wp:meta_key>wpcf-lookbook-front-image</wp:meta_key>
<wp:meta_value><![CDATA[]]></wp:meta_value>
</wp:postmeta>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)