const regex = /<(wp:postmeta)>\s*<(wp:meta_key)>\s*wpcf-lookbook-front-image\s*<\/\2>\s*<(wp:meta_value)>[\s\S]*?<\/\3>\s*<\/\1>\s*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(wp:postmeta)>\\s*<(wp:meta_key)>\\s*wpcf-lookbook-front-image\\s*<\\\/\\2>\\s*<(wp:meta_value)>[\\s\\S]*?<\\\/\\3>\\s*<\\\/\\1>\\s*', 'g')
const str = ` <wp:postmeta>
<wp:meta_key>wpcf-lookbook-front-image</wp:meta_key>
<wp:meta_value><![CDATA[]]></wp:meta_value>
</wp:postmeta>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}