re = /<(wp:postmeta)>\s*<(wp:meta_key)>\s*wpcf-lookbook-front-image\s*<\/\2>\s*<(wp:meta_value)>[\s\S]*?<\/\3>\s*<\/\1>\s*/
str = ' <wp:postmeta>
<wp:meta_key>wpcf-lookbook-front-image</wp:meta_key>
<wp:meta_value><![CDATA[]]></wp:meta_value>
</wp:postmeta>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end