import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(wp:postmeta)>\\s*<(wp:meta_key)>\\s*wpcf-lookbook-front-image\\s*<\\/\\2>\\s*<(wp:meta_value)>[\\s\\S]*?<\\/\\3>\\s*<\\/\\1>\\s*";
final String string = " <wp:postmeta>\n"
+ " <wp:meta_key>wpcf-lookbook-front-image</wp:meta_key>\n"
+ " <wp:meta_value><![CDATA[]]></wp:meta_value>\n"
+ " </wp:postmeta>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}