using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(wp:postmeta)>\s*<(wp:meta_key)>\s*wpcf-lookbook-front-image\s*<\/\2>\s*<(wp:meta_value)>[\s\S]*?<\/\3>\s*<\/\1>\s*";
string input = @" <wp:postmeta>
<wp:meta_key>wpcf-lookbook-front-image</wp:meta_key>
<wp:meta_value><![CDATA[]]></wp:meta_value>
</wp:postmeta>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}