re = /(((\+)|(\ ))(((\%27)|(\'))|union|select|delete|insert|or|alter|drop|and)(((\+)|(\ ))))/
str = '10+UNION+all+select+password,+null,+null,+null\'
select * from user or userdetails
droping'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end