$re = '/(((\+)|(\ ))(((\%27)|(\'))|union|select|delete|insert|or|alter|drop|and)(((\+)|(\ ))))/';
$str = '10+UNION+all+select+password,+null,+null,+null\'
select * from user or userdetails
droping';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);