package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(((\+)|(\ ))(((\%27)|(\'))|union|select|delete|insert|or|alter|drop|and)(((\+)|(\ ))))`)
var str = `10+UNION+all+select+password,+null,+null,+null'
select * from user or userdetails
droping`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}