import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(((\\+)|(\\ ))(((\\%27)|(\\'))|union|select|delete|insert|or|alter|drop|and)(((\\+)|(\\ ))))";
final String string = "10+UNION+all+select+password,+null,+null,+null'\n"
+ "select * from user or userdetails\n"
+ "droping";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}