const regex = /(((\+)|(\ ))(((\%27)|(\'))|union|select|delete|insert|or|alter|drop|and)(((\+)|(\ ))))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(((\\+)|(\\ ))(((\\%27)|(\\\'))|union|select|delete|insert|or|alter|drop|and)(((\\+)|(\\ ))))', 'g')
const str = `10+UNION+all+select+password,+null,+null,+null'
select * from user or userdetails
droping`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}