$re = '/string name="(.*)">[^%1\n]*</';
$str = '<!-- Reply to message -->
<string name="mail_author_wrote">%1$s wrote…</string>
<string name="mail_hint_recipient">Recipient</string>
<string name="mail_hint_subject">Subject</string>
<string name="mail_hint_body">Body</string>
<string name="mail_send_to">"Send a message to %1$s"</string>
<string name="mail_send">Send a message</string>
<string name="mail_notification_msg">New message from</string>
<string name="mail_reply_to">Reply to %1$s</string>
<string name="mail_notification_author">from</string>
<string name="mail_theirs">View their message</string>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);