using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"string name=""(.*)"">[^%1\n]*<";
string input = @"<!-- Reply to message -->
<string name=""mail_author_wrote"">%1$s wrote…</string>
<string name=""mail_hint_recipient"">Recipient</string>
<string name=""mail_hint_subject"">Subject</string>
<string name=""mail_hint_body"">Body</string>
<string name=""mail_send_to"">""Send a message to %1$s""</string>
<string name=""mail_send"">Send a message</string>
<string name=""mail_notification_msg"">New message from</string>
<string name=""mail_reply_to"">Reply to %1$s</string>
<string name=""mail_notification_author"">from</string>
<string name=""mail_theirs"">View their message</string>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}