const regex = /string name="(.*)">[^%1\n]*</g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('string name="(.*)">[^%1\\n]*<', 'g')
const str = `<!-- Reply to message -->
<string name="mail_author_wrote">%1\$s wrote…</string>
<string name="mail_hint_recipient">Recipient</string>
<string name="mail_hint_subject">Subject</string>
<string name="mail_hint_body">Body</string>
<string name="mail_send_to">"Send a message to %1\$s"</string>
<string name="mail_send">Send a message</string>
<string name="mail_notification_msg">New message from</string>
<string name="mail_reply_to">Reply to %1\$s</string>
<string name="mail_notification_author">from</string>
<string name="mail_theirs">View their message</string>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}