import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "string name=\"(.*)\">[^%1\\n]*<";
final String string = "<!-- Reply to message -->\n"
+ " <string name=\"mail_author_wrote\">%1$s wrote…</string>\n"
+ " <string name=\"mail_hint_recipient\">Recipient</string>\n"
+ " <string name=\"mail_hint_subject\">Subject</string>\n"
+ " <string name=\"mail_hint_body\">Body</string>\n"
+ " <string name=\"mail_send_to\">\"Send a message to %1$s\"</string>\n"
+ " <string name=\"mail_send\">Send a message</string>\n"
+ " <string name=\"mail_notification_msg\">New message from</string>\n"
+ " <string name=\"mail_reply_to\">Reply to %1$s</string>\n"
+ " <string name=\"mail_notification_author\">from</string>\n"
+ " <string name=\"mail_theirs\">View their message</string>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}